Samsung Moment/Win7 x64

Feb 24, 2010 at 8:59 AM
Edited Feb 24, 2010 at 9:04 AM

Having a few issues with Droid Explorer, haven't been able to find any current discussions about the Samsung Moment, so I figured I'd start one.  I'm not sure if it's the drivers, the software, the fact that it's 64 bit, the fact that it's an underdog Android phone, or what.  But a lot doesn't seem to work.

I've opened a Debug Console and tried a few of the things that didn't work.  The biggie, the one I'd REALLY like to get going, is the Shell.  It loads to a black screen with a flashing pipe cursor.  No debugging output is printed.  It'll stay there for as long as I leave it.  If I hit a key on the keyboard, I get:

 

[Program] Index was outside the bounds of the array. - System.IndexOutOfRangeException: Index was outside the bounds of the array.
   at DroidExplorer.Plugins.UI.ShellConsole.GetLocation in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Plugins\UI\ShellConsole.cs:line 271
   at DroidExplorer.Plugins.UI.ShellConsole.shell_KeyPressObject sender, KeyPressEventArgs e in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Plugins\UI\ShellConsole.cs:line 172
   at System.Windows.Forms.Control.ProcessKeyEventArgsMessage& m
   at System.Windows.Forms.Control.WmKeyCharMessage& m
   at System.Windows.Forms.Control.WndProcMessage& m
   at System.Windows.Forms.RichTextBox.WndProcMessage& m
   at System.Windows.Forms.Control.ControlNativeWindow.WndProcMessage& m
   at System.Windows.Forms.NativeWindow.CallbackIntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam

If I hit Ctrl+C, I get a busted 'prompt'.  A space, then an octothorpe (#), another space, a dollar sign ($), and the cursor below.  I can now type anything, but it won't let me run most commands. The exit command, works for some reason.  Nothing is printed to the debug console as I type anything here including exit.

Another problem I had was getting it to list installed applications in Package Manager.  Using the Debug Console again, I tracked the issue down to Droid Explorer not being able to copy the private apps off the phone, and reasonably so.  I temporarily removed all the troublesome apps and the rest now display, but each app uses the default box icon. EDIT: Never mind, just the top bunch of apps didn't have the correct icons.

Rebooting doesn't seem to work while booted to the OS, but works when in Recovery.  Not sure if this is by design or not.

I also had some intermittent issues with the file browsing aspect.  It would randomly tell me that a particular folder wasn't accessible.  I believe those issues to be more phone-related though, as I seem to lose the ability to do anything between my phone and computer, and have to reboot the phone to fix it.

Surprisingly, what would seem like the two most tricky plugins, Screenshot and Screencast, both work just fine, no problems there.  The LogCat Console also works as expected.  Obviously, as mentioned above, the Debug Console works as well.

Those are about all I've actually tested out.  I'd love to help get this program up and running correctly for the Moment and I'm willing to offer my assistance in any way possible.  Unfortunately I can't assist in the actual development, but I can provide whatever additional information and/or testing you may need to be able to check into this further. Thanks for your time and for providing such an essential utility for the Android platform!