Droid Explorer does not find Droid Phone

Apr 14, 2010 at 8:26 PM

I installed Droid Explorer (8.4.3 x86) on WINXP Pro laptop.

When I run Droid Explorer it does not find the phone and stays on "Select Device" window. 

"Safely Remove Hardware" shows phone as: Motorola A855 USB Device / Generis volume (E:)

Windows Explorer shows a "Removable Disk (E)", but when i view drive a pop-up says "Please insert a disc into dirve E"

HELP!

Apr 14, 2010 at 8:36 PM

I just noticed I accidently downloaded and installed the "Standalone' version not the "Setup" Version.

Is this the problem?  Should I uninstall the "Standalone" version and install the "Setup" version? 

What is the difference between the 2 versions?

 

Coordinator
May 16, 2010 at 2:01 PM

The only difference between the 2 versions is one contains all the necessary files in the install, the other is a smaller initial download, but gets additional files from the internet during the install.

What phone are you connecting?
Is it Rooted?
What ROM are you running?
Did you enable USB Debugging on the phone? Settings -> Applications -> Development -> USB Debugging

May 16, 2010 at 9:08 PM

Verizon Droid

Is it suppossed to be rooted?

I just rooted my phone and now Droid Explorer works. 

 

..

 

..

Coordinator
May 21, 2010 at 2:53 AM

Glad you got it working.

Jun 14, 2010 at 7:30 AM

@camalot: I'm new to Android phone. Could you please teach me what is rooted phone? and how to root droid phone?

Thank in advance,

 

Jun 14, 2010 at 7:31 AM

I am on X10 which is my first droid phone. Droid Explorer could not find my phone too. I think my phone might not be rooted yet.

Coordinator
Jun 14, 2010 at 4:04 PM

@nite_swinger: its not finding your phone because it is not rooted yet. If you are not sure if it is rooted, then it is not rooted. I am not sure if the X10 has been rooted, you can read the XDA X10 forums and find out if it has been, and how to do it. Every device has different procedures on rooting, so I cannot help you on rooting your device.

Jun 15, 2010 at 3:04 AM
@camalot: Thank you for your info.
Jun 15, 2010 at 6:47 PM

I am have a similar issue. Droid Explorer is installed but not detecting my Moto Droid. I have Froyo installed and rooted with Busybox and adb capabilities. When I start up the explorer it just says device not detected. Any ideas? ( and yeah debugging is enabled.. ) maybe Froyo is compatible  yet?

 

Coordinator
Jun 16, 2010 at 8:59 PM

@akasoldats

Did you already have drivers for your Droid installed and you installed the drivers with Droid Explorer?

try these steps:


right-click "My Computer"
click "Manage"
select "Device Manager"
expand "Android Phone"
right-click whatever is listed
click "Update Driver Software"
click "Browse my computer for driver software"
click "Let me pick from a list of device drivers on my computer"
select "Mot Composite ABD Interface"
click "Next"

you should be done or close to (click finish or close or whatever)