This project has moved and is read-only. For the latest updates, please go here.

Moment2.1, XP x64... errors...

May 17, 2010 at 3:17 PM
I'm an old WinMo guy who has taken the leap to Android. I love it, but it's like learning a foreign language to me. Anyway, running XP x64 SP3 and getting the following error when I attempt an install... (USB Debugging is OFF for this error. The same error occurs when it is ON.) === "System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: Not Installed at DroidExplorer.Bootstrapper.UI.WizardForm.GetSdkPath() in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\UI\WizardForm.cs:line 315 at DroidExplorer.Bootstrapper.Panels.DownloadPanel..ctor(IWizard wizard) in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\Panels\DownloadPanel.cs:line 58 --- End of inner exception stack trace --- at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType) at System.RuntimeMethodHandle.InvokeConstructor(Object[] args, SignatureStruct signature, RuntimeTypeHandle declaringType) at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) at DroidExplorer.Bootstrapper.UI.WizardForm.BaseNavigate(WizardStep step, String additionalText) in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\UI\WizardForm.cs:line 228 at DroidExplorer.Bootstrapper.UI.WizardForm.Navigate(Int32 index) in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\UI\WizardForm.cs:line 135" === Any ideas? My goal was originally to utilize the Screencast plugin, but now I want all of it!
May 21, 2010 at 3:52 AM

This looks like its the same issue as with Vista x64. It has to do with windows installer writing to the x64 section of the registry, when it should not be. The installers are set as x86 binaries, so they should be using the "x86" sections, for some reason, on some versions of XP x64 (i think SP3 only), and Vista x64 this happens. It installs as expected on Win7 x64. I know about the issue and will correct it as soon as i figure out the exact problem and the solution. Thank you for letting me know that this is also happening with XP.

May 24, 2010 at 2:15 AM

I'm running Win7 x64 and had the same exact problem as the first poster.  OS is up to date with patches, etc.  Tried normal and standalone installs with same results.

May 24, 2010 at 2:56 AM

I have a machine with Win 7 x64 on it now, and I am also setting up a Vista x64 & XP x64 VM. The next release will focus entirely on correcting the x64 issues