Installation Problems

Jun 1, 2010 at 9:38 AM

,

I am having trouble installing Droid Explorer 0.8.5.1, I Have downloaded the zip file but when I try to run either of the files contained I get the error message 'DroidExplorer.Bootstrapper has encountered a problem and needs to close. We are sorry for the inconvenience' My colleague has also tried to install the application on his PC and receives the same message, Has anybody else received this error and if so how do I overcome the problem?

I have also tried installed older versions but receieved the same message.

Many Thanks

Coordinator
Jun 2, 2010 at 7:06 PM
What version of Windows are you running? I have seen this happen if you do not have .NET 3.5 SP1 installed on the system. Also make sure you are installing the x86 version for 32 bit windows and x64 version for 64 bit windows.
Jun 3, 2010 at 9:19 AM

The problem was I did not have .NET 3.5 SP1 installed on the system. I have now installed this and all works fine :-)

Jun 9, 2010 at 1:44 AM
I confirmed that i have .NET 3.5 SP1 installed but my installation of Droid Explorer is unsuccessful with an error: System.UnauthorizedAccessException: Access to the path 'adb.exe' is denied. at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive) at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive) at DroidExplorer.Bootstrapper.Panels.DownloadPanel.SdkPathCleanup() in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\Panels\DownloadPanel.cs:line 251 at DroidExplorer.Bootstrapper.Panels.DownloadPanel.RunSetup() in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\Panels\DownloadPanel.cs:line 178
Coordinator
Jun 9, 2010 at 10:44 AM

I've got additional checks for this in the upcoming build. The problem is ADB is still running when the tools try to install. To cleanly install now, check if adb is running using task manager. if it is, open a command window, change directories to the sdk directory in the install path of Droid Explorer (c:\program files\droid explorer\sdk is the default). then run

adb kill-server
Now you should be able to successfully run the install

Jun 9, 2010 at 9:08 PM
Thanks for responding but I am still having issues even after killing the runaway adb job. Task manager, shows not 1 but 3 instances of adb .Killing all 3 (thro' end tasks @ the manager) does not help. Please hlep! By the way, am using the latest version of the droid o/s today and still doesnt work.
Coordinator
Jun 11, 2010 at 12:47 PM

try uninstalling droid explorer from the control panel before you kill the adb server, if it is there.

Jul 19, 2010 at 5:39 AM

I am still running into the above problem.  Have Windows Vista 64.  There is no "sdk"  file within the droid explorer file on my computer.  I did a CD to c:\program files\droid explorer\ and ran the "adb kill-server" command (there was no error displayed).
I also ran the command "adb disconnect" under the normal command prompt.  Still no successful install.

 

Here is my error log from the install.

 

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ArgumentException: Not Installed
   at DroidExplorer.Bootstrapper.UI.WizardForm.GetSdkPath() in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\UI\WizardForm.cs:line 315
   at DroidExplorer.Bootstrapper.Panels.DownloadPanel..ctor(IWizard wizard) in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\Panels\DownloadPanel.cs:line 58
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)
   at System.RuntimeMethodHandle.InvokeConstructor(Object[] args, SignatureStruct signature, RuntimeTypeHandle declaringType)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at DroidExplorer.Bootstrapper.UI.WizardForm.BaseNavigate(WizardStep step, String additionalText) in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\UI\WizardForm.cs:line 228
   at DroidExplorer.Bootstrapper.UI.WizardForm.Navigate(Int32 index) in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\UI\WizardForm.cs:line 135

Please let me know what I'm doing wrong!  Thanks, Shane

Coordinator
Jul 19, 2010 at 11:12 AM

There are known issues with being able to install on XP & Vista 64 bit systems. I am working on it, but it has to do with writing to the registry, which doesn't work how it should. Try using an existing SDK, and download the sdk from http://developer.android.com. I actually have not tested it under this scenerio, but you may get lucky. With every build, I try different things to get it working in XP & Vista 64 bit, I just haven't found the working solution yet.

Jul 23, 2010 at 9:33 PM

I was having a similar problem. Installing on 32 bit Windows 7.  I saw the adb kill-server command and wondered if maybe my old AndroidSDK was effecting it.  I pulled it up from the old path and did the adb kill-server and next time I installed it went all the way through, but also still had some error at the end which I ignored. When I started up Droid Explorer, it worked. 

Coordinator
Jul 24, 2010 at 2:53 AM

the newest build, jirafaBo support using your own android sdk for this reason. it is disabled by default during install.

Jul 25, 2010 at 9:45 AM

Hi i got som problem too i use win7 x86 and it say im out of memory??

 

here u se the error... http://img801.imageshack.us/img801/354/androidsdk.png

 

i was 1 time able to start the explorer but after that my pc crashed :(

sorry for my bad english^^

Coordinator
Jul 26, 2010 at 11:03 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Jul 26, 2010 at 4:56 PM

thx