Droid Incredible

Aug 8, 2010 at 8:55 PM
Edited Aug 8, 2010 at 8:55 PM
So I have been looking for a program like this for a while. I know that the latest version has trouble starting its service so I tried a few older versions but was unable to explore the device. Is there something I am missing or is the Incredible just not supported? Thanks, Josh
Aug 8, 2010 at 9:37 PM
Edited Aug 8, 2010 at 10:49 PM

Nevermind I just updated busybox to 1.16.2 (couldn't find 1.17.1) and it fixed my problem.

Edit: Ok new problem, when the phone is booted into the OS I can't explore /data and I noticed that I didn't get prompted for superuser access.  Anyway to do this or does it just not go there? (Also just tried it in recovery and I still can't explore it)

I was going to try su in the console but when I type something I get this from debug:

[Program] Index was outside the bounds of the array. - System.IndexOutOfRangeException: Index was outside the bounds of the array.
   at DroidExplorer.Plugins.UI.ShellConsole.GetLocation in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Plugins\UI\ShellConsole.cs:line 356
   at DroidExplorer.Plugins.UI.ShellConsole.shell_KeyPressObject sender, KeyPressEventArgs e in f:\Projects\DroidExplorer\trunk\DroidExplorer\DroidExplorer.Plugins\UI\ShellConsole.cs:line 247
   at System.Windows.Forms.Control.OnKeyPressKeyPressEventArgs e
   at System.Windows.Forms.Control.ProcessKeyEventArgsMessage& m
   at System.Windows.Forms.Control.ProcessKeyMessageMessage& m
   at System.Windows.Forms.Control.WmKeyCharMessage& m
   at System.Windows.Forms.Control.WndProcMessage& m
   at System.Windows.Forms.TextBoxBase.WndProcMessage& m
   at System.Windows.Forms.RichTextBox.WndProcMessage& m
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessageMessage& m
   at System.Windows.Forms.Control.ControlNativeWindow.WndProcMessage& m
   at System.Windows.Forms.NativeWindow.CallbackIntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam


Aug 9, 2010 at 11:28 AM

Even though the service fails to start, it will not stop DE from working. The service just handles the device being displayed when you open Windows Explorer to "Computer" and you see all your drives and devices. The service adds/removes the device from there. Everything else will still work.

The console has some issues on some devices, try the latest version because it has possible fixes for that issue, plus it has further debugging info.


I will look in to you not being able to explorer /data

Aug 9, 2010 at 8:51 PM
Edited Aug 9, 2010 at 8:54 PM

Thanks for the response.  The latest version does allow me to use the console so thanks for that.

I noticed in the debug window that when I click on /data or any other areas that require root it returns:

[CommandRunner] adb.exe -s HT04Y******* shell busybox ls -lF --color=never "/data/"
[CommandRunner] ls: can't open '/data/': Permission denied

So it seems it just isn't acquiring root.  When I do the same command in the console after doing su it works as expected.

Is there anything I can change or should I just wait?


Aug 10, 2010 at 2:00 AM

theres nothing you can do, I have to look in to why it does not get root before getting the directory. I am glad that the shell console is working now. I can check that off my list :)