Read only?

Apr 22, 2011 at 3:57 AM

Hi, I've recently rooted a samsung Epic (galaxy S) and for some reason Droid Explorer is only able to read my phone, not write. I tried deleting a file and I tried adding a file. Droid Explorer acted like it was doing just that, but nothing happened.

 

How do I get write access?

 

My phone is running EXT4 instead of the regular samsung file system.

Coordinator
Apr 22, 2011 at 11:36 AM

The file systems are only read on the device, especially in the /system. Droid explorer does not change this, for security reason. In up coming versions, Droid Explorer will be able to change the file system to Write for you. It has just been a struggle to figure out how to implement the ability to change the file system, but not to risk security of the device.

You can manually remount your file system to Read/Write using the mount command in a console window.

Apr 27, 2011 at 11:30 PM

What is the point of even using Droid Explorer, if it cant copy, delete, move or get write access to my system rooted device? and why would the security risk of my device be a stumbling block for implementing this ability? Maybe there needs to be a disclaimer on this site informing everyone that Droid Explorer doesn't really work at. 

Coordinator
Apr 28, 2011 at 1:56 AM

I'm not saying it wont be implemented, I am saying at the present time, there is nothing built in that will convert the file system to read/write. you can copy from /system, just by default, you cannot delete or write to it.

Sep 7, 2011 at 8:56 AM

I agree with tpmjb and jdecho: there MUST be something built in that will convert the file system to read/write. If someone use at his own risk Droid explorer, is because knows what is doing!!!