Windows 7 64 Bit Installation Problems

May 29, 2011 at 10:04 PM

Ok, like everyone else here I am getting the following error:


System.UnauthorizedAccessException: Access to the path 'adb.exe' is denied.
   at System.IO.Directory.DeleteHelper(String fullPath, String userPath, Boolean recursive)
   at System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)
   at DroidExplorer.Bootstrapper.Panels.DownloadPanel.SdkPathCleanup() in s:\projects\CSharp\droidexplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\Panels\DownloadPanel.cs:line 251
   at DroidExplorer.Bootstrapper.Panels.DownloadPanel.RunSetup() in s:\projects\CSharp\droidexplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\Panels\DownloadPanel.cs:line 181

I am trying to do a new install of the most recent version of DE. I did have a previous version installed, but it would never work properly with my phone. I downloaded the .Net FX 3.5 file, but all that happens whenever I run it is the Yes/No menu pops up, It does not appear to install anything. I am not sure if this is due to the fact that I have .Net FX 4.0 installed already. I have never had to do any command prompts for ADB, so I am not sure how to go about changing the directory as previous instructions mentioned.

Any help would be appreciated. Thanks.

May 30, 2011 at 7:53 PM

make sure all instances of adb are killed before installing. The Droid Explorer installer tries to kill it, but sometimes it is unable to. Try running, from the command line, "adb kill-server". And maybe even "net stop droidexplorerservice", then "adb kill-server". 

Jun 1, 2011 at 5:39 AM

I tried doing that, but when I type "adb kill-server" into the cmd.exe, but I get the following error message: 'adb' is not recognized as an internal or external command, operable program or hatch file.

Jun 1, 2011 at 11:53 AM

you need to navigate to the directory that the sdk is installed at in the command prompt.

c:> cd c:\android-sdk\platform-tools
c:\android-sdk\platform-tools> adb kill-server

Jun 1, 2011 at 7:36 PM

Ok, well the problem seems to be that I don't have the android-sdk installed at all. I was trying to do that when I first had the problem, but I couldn't get the stupid SDK to acknowledge that I had installed the equally stupid Java SDK. Let's see if I can convince it this time.

Mar 12, 2012 at 1:06 AM

Probably my problem is exatly the same....

my problem.

but my problem is on windows vista ultimate x64 sp2.