htc sensation new to droid explorer/coding... help opening data file?

Aug 11, 2011 at 2:21 AM

i've just got droid explorer installed, and im connected with my htc sensation and can see folder structure, but when i click on some folders they do not open up for me? i've installed busybox 1.18.4 it's s-off and should be good to go from what i've read/researched.

When i click on data. it just doesnt open up to show my files or my apps.

Any helps would be appreciated.

Aug 11, 2011 at 2:27 AM
Edited Aug 11, 2011 at 3:04 AM

Well i just ran es file explorer and tried going to data, and that works.

Coordinator
Aug 11, 2011 at 2:38 PM

Can you open the debug console and then navigate to the directory that doesn't expand and post here what is in the debug console. The debug console is the little "bug" in the toolbar.

Aug 11, 2011 at 5:07 PM

Hi, Thanks For Reply

 

[CommandRunner] adb.exe -s SH179T501606 shell busybox ls -lF --color=never "/data/"
[CommandRunner] ls: can't open '/data/': Permission denied

[CommandRunner] adb.exe -s SH179T501606 shell busybox ls -lF --color=never "/data/"
[CommandRunner] ls: can't open '/data/': Permission denied

Aug 18, 2011 at 5:56 AM

Any Ideas guys?

Thanks

Coordinator
Aug 31, 2011 at 8:22 PM

this has to do with the default permissions of /data. ADB, which is what Droid Explorer uses to currently communicate with your device, does not have 'root' access in the shell and some directory like /data dont allow you to access them unless you have root permissions. This is something that is being worked on, but I do not have an ETA yet to when it will be released. Another option is to change the permissions to /data with chmod.