This project has moved and is read-only. For the latest updates, please go here.

Error: System.InvalidOperationException: Cannot start service

Jun 19, 2012 at 2:03 AM
Edited Jun 19, 2012 at 2:38 AM

It would be nice to try this app, but without it installing, it seems impossible.

1) Installation will not recognize currently installed Android SDK when browsed to proper folder, which works with both QtADB and MyPhoneExplorer.

2) Android SDK downloads & installs then I repeatedly get error:

********** Error message begin ***********

System.InvalidOperationException: Cannot start service DroidExplorerService on computer '.'. ---> System.ComponentModel.Win32Exception: The service did not respond to the start or control request in a timely fashion
   --- End of inner exception stack trace ---
   at System.ServiceProcess.ServiceController.Start(String[] args)
   at System.ServiceProcess.ServiceController.Start()
   at DroidExplorer.Bootstrapper.Panels.StartServicePanel.StartService() in d:\Development\projects\csharp\droidexplorer\trunk\DroidExplorer\DroidExplorer.Bootstrapper\Panels\StartServicePanel.cs:line 53

********** Error message End ***********

Any useful suggestions appreciated. :)

I would prefer to use default existing android SDK, when possible. 

I tried repair twice followed by reboot with no success.


Droid Explorer: DroidExplorer.
PC Platform:     Windows XP Pro SP3
Device:               Samsung GT-I9000
ROM:                  Stock JW5 (2.3.6), Semaphore 2.7.4 Kernel


JUST NOTICED: I am not able to START DroidExplorerService; Error 1053

Jun 28, 2012 at 1:51 PM

I would just like to add that I am having the exact same issue as Catalyst2012 on 2 of my computers.  1 is a Win XP Pro SP3 machine and the other is a Win 7 Ultimate 32bit machine.  And I also cannot start DroidExplorerService....I get same 1053 error.


I also tried to reboot and run repair with DroidExplorer.

Jul 18, 2012 at 9:44 AM

The error is beause it can not load the assembly.

The "D" drive is shown just for debug info not a reference.


The error is:

Unhandled Exception: Unhandled Exception: System.BadImageFormatException: Could not load file or assembly 'DroidExplorer.Core, Version=, Culture=neutral, PublicKeyToken=9d8102502465d3e8' or one of its dependencies. An attempt was made to load a program with an incorrect format. File name: 'DroidExplorer.Core, Version=, Culture=neutral, PublicKeyToken=9d8102502465d3e8' at DroidExplorer.Service.Program.Main(String[] args)

Maybe need to recompile the project.

Any comments?