DroidExplorer.0.8.8.6.x86 Unable to locate Android SDK directory

Aug 20, 2012 at 2:36 AM
Edited Aug 20, 2012 at 2:47 AM

DroidExplorer.0.8.8.6.x86.exe installer won't recognize Android SDK folder on C: drive. It is from original Android Development site and was updated earlier today via SDK Manager.exe.

I tried browsing to Android SDK folder, Platform Tools folder, and Tools folder, with no success. I had to abort installation.

I get error: "Unable to identify the specified path as a valid Android SDK directory".

DroidExplorerInstall.log is empty.

I disabled Antivirus just in case and tried twice: same error as above.

Windows XP SP3

Thank you.

 

 

Coordinator
Aug 20, 2012 at 2:29 PM

can you re-run the installer with "/l" that will enable logging and then post the log file here (or email to me camalot at gmail). the log file is created (bug) but empty if that switch doesn't exist.  did you install the SDK using the installer originally or used the zip? If you installed it, was there a value to the SDK populated in the text box?

Coordinator
Aug 20, 2012 at 7:58 PM

i just tested the x86 installer on an XP SP3 Virtual Machine that I freshly installed the Android SDK. It picked up the SDK without any issues.

Aug 22, 2012 at 8:14 PM

Thank you for your prompt reply!

1. I re-ran the installer DroidExplorer.0.8.8.6.x86.exe "/I" as you indicated with the same results; log is huge so I will email it to you rather than posting here.

2. After the installer failed to identify my currently installed Android SDK installation, I chose to download SDK via the DroidExplorer.0.8.8.6.x86.exe installer, but did not re-install it over concerns that 3 existing and working apps that use Android SDK may be impacted.

3. Are you able to indicate what exact files the installer is looking for in the SDK directory? I have the minimal defaults + Tools, Platform Tools, AVD Manager.exe, SDK Manager.exe. Otherwise I am clueless why my currently installed and functioning SDK is not being recognized.

Thank you.

 

Coordinator
Aug 22, 2012 at 8:30 PM

How did you choose to download the SDK via the DroidExplorer 0.8.8.6 installer? The functionality was removed to use a "subset sdk". It was better to let google handle the SDK distribution, that way the "subset sdk" never actually conflicts with a "full sdk" installed on the machine.

I would say run the SDK manager, and make sure the tools/platform-tools are updated.

 

Droid explorer looks for 2 key executables to verify the sdk, aapt.exe and adb.exe, they are in platform-tools.

Aug 22, 2012 at 9:01 PM

There is a link on the lower left (as I recall) when DE installer is browsing for the SDK. It downloads from Android Developer site, but as far as I can tell does not install it, so I did not install it. If I understand correctly, Droid Explorer would install a subset (?) in its own directory? That would be a good idea.

Android SDK Tools R 20.0.3, and Android SDK Platform-tools R 14 were updated via SDK Manager before any any attempts to install Droid Explorer.

aapt.exe and adb.exe are both located in C:\ANDROID\Android-SDK\platform-tools. Perhaps there is a conflict with my directory names?

 

 

 

Coordinator
Aug 22, 2012 at 9:11 PM

Droid Explorer does not install its own. It used to. It was not ideal, as I now had to maintain a version of the sdk and make sure it was up to date with the current SDK or it would cause conflicts with people that actually have a "full sdk" installed. 

The link, yes, it takes you to the download of the SDK, but it does not actually install it. That has to be done manually. 

I will try to do an install just like your structure on a VM as soon as I can. 

Aug 23, 2012 at 10:26 PM

I would like to report I now have Droid Explorer installed and working.

Per your advice, I

1. opened the Android SDK Manager,
2. installed Android 4.1 (API 16)-->SDK Platform,
3. ran the Droid Explorer installer and installed successfully.

Thank you for your excellent assistance!

 

 

 

 

 

 

 

 

Sep 26, 2012 at 11:26 PM
Edited Sep 26, 2012 at 11:34 PM
CATALYST2012 wrote:

I would like to report I now have Droid Explorer installed and working.

Per your advice, I

1. opened the Android SDK Manager,
2. installed Android 4.1 (API 16)-->SDK Platform,
3. ran the Droid Explorer installer and installed successfully.

Thank you for your excellent assistance!

I can confirm that I was having the same problem you've reported when I've tried to install the 0.8.8.7 version of Droid Explorer, and finally after installing SDK platform [Android 4.1 (API 16)]  the showing error : "Unable to identify the specified path as a valid Android SDK directory" doesn't appair again and I got it installed successfully.

I'm using Windows 7 64bit

Coordinator
Sep 27, 2012 at 2:47 PM

I am going to try and remove this requirement in the future. I have to make sure that nothing is actually using the platform stuff before i can remove the requirement though.

Nov 2, 2012 at 5:25 AM

same problem, fixed same way, was installing dron 0.8.8.8 on win 7 64bit home professional. took good 40 minutes of searching to find this solution, should ideally be posted on main page until fixed.

 

thanks

Nov 27, 2012 at 4:59 PM
Edited Nov 27, 2012 at 5:36 PM

I am having the same issue.  I am using Windows 7 Ultimate 64-bit.  Trying with DroidExplorer.0.8.8.8.x64.Setup.zip and same problem with 0.8.8.7

 

First I downloaded the SDK via the link provided in the installation program.  This results in a zip file: adt-bundle-windows-x86_64.zip

I extract it to D:\adt-bundle-windows-x86_64\ and now I have:

D:\adt-bundle-windows-x86_64\adt-bundle-windows\

and inside are two directories eclipse\ and sdk\

 

I then verify that it works by running the eclipse.exe and it starts up fine.  It failed the first time because I didn't have 64-bit Java, but I went ahead and got that, installed it, and it starts up fine now.

 

Then I run the Droid Explorer installation.  It gets to the step "Use Existing Android SDK".  The box is blank but it won't accept any of the directories.  Above camalot says it looks for aapt.exe and adb.exe and I found these in:

D:\adt-bundle-windows-x86_64\adt-bundle-windows\sdk\platform-tools\aapt.exe

 D:\adt-bundle-windows-x86_64\adt-bundle-windows\sdk\platform-tools\adb.exe

 

I select D:\adt-bundle-windows-x86_64\adt-bundle-windows\sdk\platform-tools

and it says "Unable to identify the specified path as a valid Android SDK directory".

I tried selecting:

D:\adt-bundle-windows-x86_64\adt-bundle-windows\sdk\

D:\adt-bundle-windows-x86_64\adt-bundle-windows\

D:\adt-bundle-windows-x86_64\

and same error message.

Nov 27, 2012 at 5:02 PM

Here is the DroidExplorerInstaller.log

 

2012-11-27 12:00:38,606 [1    ] [INFO ] [DroidExplorer.Bootstrapper.Program] System Info: Microsoft Windows NT 6.1.7601 Service Pack 1 x64
2012-11-27 12:00:38,623 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.Program] Starting setup with arguments: /l
2012-11-27 12:00:38,627 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.Program] Mode set to install
2012-11-27 12:00:38,635 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.UI.WizardForm] Initializing Wizard Form
2012-11-27 12:00:38,714 [1    ] [WARN ] [DroidExplorer.Bootstrapper.UI.WizardForm] Registry key 'SOFTWARE\DroidExplorer\InstallPath' was not found on the system: Microsoft Windows NT 6.1.7601 Service Pack 1
2012-11-27 12:00:38,716 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.UI.WizardForm] Loading Configuration
2012-11-27 12:00:38,979 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.UI.WizardForm] Navigating to first panel
2012-11-27 12:00:38,987 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallStartPanel] Creating Panel: InstallStartPanel
2012-11-27 12:00:38,990 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallStartPanel] Creating Panel: DroidExplorer.Bootstrapper.Panels.InstallStartPanel
2012-11-27 12:00:38,992 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.UI.WizardForm] Navigating to step DroidExplorer.Bootstrapper.Panels.InstallStartPanel
2012-11-27 12:00:39,000 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallStartPanel] Initializing Panel: InstallStartPanel
2012-11-27 12:00:40,103 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallDroidExplorerPanel] Creating Panel: InstallDroidExplorerPanel
2012-11-27 12:00:40,110 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallDroidExplorerPanel] Creating Panel: DroidExplorer.Bootstrapper.Panels.InstallDroidExplorerPanel
2012-11-27 12:00:40,113 [1    ] [DEBUG] [DroidExplorer.Bootstrapper.UI.WizardForm] Navigating to step DroidExplorer.Bootstrapper.Panels.InstallDroidExplorerPanel
2012-11-27 12:00:40,129 [3    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallDroidExplorerPanel] Extracting installer
2012-11-27 12:00:40,897 [3    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallDroidExplorerPanel] Running installer
2012-11-27 12:00:49,540 [3    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.InstallDroidExplorerPanel] Installer exited with exit code: 0
2012-11-27 12:00:49,559 [3    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.RunningProcessesPanel] Creating Panel: RunningProcessesPanel
2012-11-27 12:00:49,563 [3    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.RunningProcessesPanel] Creating Panel: DroidExplorer.Bootstrapper.Panels.RunningProcessesPanel
2012-11-27 12:00:49,565 [3    ] [DEBUG] [DroidExplorer.Bootstrapper.UI.WizardForm] Navigating to step DroidExplorer.Bootstrapper.Panels.RunningProcessesPanel
2012-11-27 12:00:50,795 [5    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.UseExistingSdkPanel] Creating Panel: UseExistingSdkPanel
2012-11-27 12:00:50,800 [5    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.UseExistingSdkPanel] Creating Panel: DroidExplorer.Bootstrapper.Panels.UseExistingSdkPanel
2012-11-27 12:00:50,803 [5    ] [DEBUG] [DroidExplorer.Bootstrapper.UI.WizardForm] Navigating to step DroidExplorer.Bootstrapper.Panels.UseExistingSdkPanel
2012-11-27 12:00:50,815 [5    ] [DEBUG] [DroidExplorer.Bootstrapper.Panels.UseExistingSdkPanel] unable to verify sdkpath: 

 

 

There is an install.log too but the installation is fine so I won't attach it unless you want to see it.  All the files got placed in C:\Program Files\Droid Explorer\

Coordinator
Nov 29, 2012 at 8:33 PM

I will look in to this for the next release. I have not installed the sdk as part of the ADT bundle so I don't know how different it is. 

 

As a side note, make sure that you install at least one platform using the SDK manager after you install the SDK. This is a known issue and I am already looking in to a solution to this.

Dec 1, 2012 at 9:53 PM

I followed the recommendation to install at least one platform.  By default, without me doing anything, it already has the Android 4.2 (API17) SDK platform installed.  So I added the "Android 4.1.2 (API16)" as well.

 

Screenshot

http://i.imgur.com/fmQkm.png

 

But still the same issue, so for some reason, it did not work for me.  Are there any registry keys that need to be set or checked?  Thank you.

Dec 1, 2012 at 10:04 PM
Edited Dec 1, 2012 at 10:11 PM

More progress: The key is to avoid the ADT version of the SDK (which is kind of hard since Google pushes that as the first option on the Downloads page).

 

Open the section called "Use an existing IDE".

then "Download the SDK Tools for Windows"

 

You'll get a file called installer_r21-windows.exe

Run that and it installs to: C:\Program Files (x86)\Android\android-sdk\

The Android SDK Manager will start after installation.

 

Download one of the SDK platforms.  I chose "Android 4.2 (API 17)".

 

After that, run the DroidExplorer installer and it installs fine.  But run it and there is a new error.

Could not find a part of the path

'C:\Users\Clevo\AppData\Roaming\DroidExplorer\a...\[Default].png'

 

Screenshot: http://i.imgur.com/m6zsb.png and 

http://i.imgur.com/iLtjc.png

I've tried deleting

C:\Users\<username>\AppData\Roaming\DroidExplorer\Data\DroidExplorer.config

but it did not help.

Dec 1, 2012 at 10:18 PM
Edited Dec 1, 2012 at 10:23 PM

I looked in the C:\Users\Clevo\AppData\Roaming\DroidExplorer\ directory and I see two directories Data\ and logs\

There are a total of 2 files in the entire DroidExplorer\ :

C:\Users\Clevo\AppData\Roaming\DroidExplorer\Data\DroidExplorer.config

C:\Users\Clevo\AppData\Roaming\DroidExplorer\logs\DroidExplorer20121201.log

There is no directory called assets\ so I created it, then

I just created a simple png file with mspaint.

C:\Users\Clevo\AppData\Roaming\DroidExplorer\assets\[DEFAULT].png

After that it ran and I could connect to it, but I can't browse anything.  I have enabled 'USB Debugging' already.

This is a Galaxy Note 2.

 

final screenshot: http://i.imgur.com/x5bRw.png

 

Thank you very much for your help.

 

EDIT: PS: It looks like only the directory assets\ has to be created.

PPS: Tried 0.8.8.7 beta but still same issue, can't browse the filesystem but connects file.

Dec 17, 2012 at 6:28 PM
Edited Dec 17, 2012 at 6:58 PM

This is a complete train wreck. 

If the correct download isn't available (and obvious) via the download link, remove the bloody link, please.

If you need something installed before running the installer, PLEASE TELL US HOW because:

... installing the confounded windows sdk installer as described above still gives the same error. To make the installer function correctly i had to (a) install only for me and (b) install the entire 4.2 SDK IN ADDITION TO the SDK tools.

This application was wonderful when i first installed it, but since it's become a PITA. I spent nearly two hours today on what should have been a 3 minute upgrade.  

Thanks for your work in the past.  

Jan 3, 2013 at 7:26 AM

Same here! I'm working more than 2 hours to install droid explorer. all SDK have been installed but it still couldn't find it!!! which file it's looking for to locate the SDK locatiom!?!!

Jul 6, 2013 at 1:54 AM
copy aapt.exe to your AppData\Local\Android\android-sdk\platform-tools folder

Droid Explorer is looking for that file, by default android adk does not have that file there anymore,
I got my copy from the Android\android-sdk\build-tools\17.0.0
Aug 7, 2013 at 7:36 AM
carl1961 is right. copy aapt.exe from build-tools\17.0.0 folder to platform-tools folder.
Aug 26, 2013 at 8:31 PM
Win 7 x64; DroidExplorer.0.8.8.11.x64. My phone is a Galaxy Nexus. Drivers are already installed, and I can easily use ADB and Fastboot.

I, too, receive the error message: "Unable to identify the specified path as a valid Android SDK directory". However, I have not installed the SDK, so that isn't a surprise. I don't need the (huge) SDK; presumably I only need the contents of the SDK platform-tools folder (plus perhaps the aapt.exe file). I created an AppData\Local\Android\android-sdk\platform-tools folder, and placed all of the SDK files for that folder there, together with aapt.exe. It didn't help.

I would like to layer Droid Explorer on top of my existing structure (hopefully without messing anything up). Can this be done? Presumably I have the correct files in an appropriate location on my drive; it's merely a question of getting Droid Explorer to recognize them during its installation process.
Mar 21 at 3:21 PM
I have found out a way to fix this.........( ERROR )---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------Here is the layout how you should have it what you should do---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Sdk path: C:\Development\adt-bundle-windows-x86_64-20131030---------That is the recommended spot where it worked for me.

copy any png image with name [DEFUALT].png to: C:\Users\Bailey Shrum\AppData\Roaming\DroidExplorer\assets

copy the aapt.exe from: C:\Development\adt-bundle-windows-x86_64-20131030\sdk\build-tools\android-4.4 (to) C:\Users\Bailey Shrum\AppData\Local\Android\android-sdk\platform-tools.

Then open sdk manger and download<
     -android sdk build-tools rev 19 & 17
     -download sdk platforms: android 4.1.2 (api 16) sdk platform, android 4.2.2 (api 17) sdk platform, android 4.3 (api 18) sdk platform & android 4.4.2 (api 19) sdk platform.
The copy aapt.exe from: C:\Development\adt-bundle-windows-x86_64-20131030\sdk\build-tools\17.0.0 (to) C:\Development\adt-bundle-windows-x86_64-20131030\sdk\platform-tools

Then when you load the program it should work. It took me a couple of tries to fix this and before you do this install Droid Explorer after you move the sdk folder to: C:\Development\adt-bundle-windows-x86_64-20131030 and when it say select sdk path redirect it to: C:\Development\adt-bundle-windows-x86_64-20131030\sdk

I hope that this fixes your problem with droid root not working. I fyou have any questions email me at: baileystephenshrum4281995@gmail.com