This project has moved and is read-only. For the latest updates, please go here.

Cannot see ANY folders or files on my phone

Oct 18, 2013 at 2:00 PM
I've gotten Droid Explorer to work, with SDK etc... However, I cannot see any of my phone folders OR files when I run Droid Explorer - The only folder I can see is a folder with the name '/' on the left-hand side of the screen, which im assuming has nothing to do with my phone. (nothing happens when I click it or double-click it).
My Phone version (HTC Sensation XE) is 4.0.3, so I originally installed the 'Android 4.0.3 (API15)' version via the SDK Manager, I later installed all the versions above that (API16, 17 and 18) to see if it worked, which it didnt. Ive also installed ALL the extras.
I've enabled USB debugging and I've tried changing between 'charge only' and 'disk drive' - neither of them make a difference.
My phone definitely connects to Droid Explorer - it shows 'HT1CNV809667' at the top of the screen, and when I click 'Connect to Device' I can see my phone under 'Devices'.
I'm basically a complete noob at all this, so I had no idea if my phone was rooted or not, or even if that matters (or if my phone needs to be rooted or unrooted). However, I downloaded 'HTC QuickRoot', which told me my phone is already unrooted when I tried to unroot it... so do I need my phone rooted?
If not, what am I doing wrong?
Nov 11, 2013 at 8:23 PM
Wow, your post was made on 18-OCT and the developer/moderator hasn't addressed/answered this yet? I'm not feeling too warm and fuzzy about this app which I was hoping would help me get some app data files...

I'm having the exact same issue but with a Moto Droid Razr Maxx running 4.1.2, NOT rooted, debugging IS enabled and active. We should be able to at least see some files listed even if non-rooted. Note: That '/' you see is the 'root' folder of the device and is always your starting point. I'm a noob at playing with my Android device as well but have 30 yrs IT experience with many, many OS's and this foray is becoming quite frustrating to say the least. I feel your pain.

Previously I had dl'd the full sdk bundle and only pulled the platform tools into a local folder in order to get the adb functions working manually. DE didn't like this directory as the sdk location and I then had to dl the sdk and then update using the manager. Finally, all was good, DE runs, I'm able to back up my device, create a backup (.ab) file BUT...

Now I find that the unpack option (available via a right click on the .ab file from Windows Explorer) is 'buggy' and may not work at all. I also read somewhere that DE is supposed to be able to open/browse the .ab files as well. No such luck here either... For now DE is a useless app for me.
Does anyone have info on this as well?
Nov 12, 2013 at 12:37 PM
This is answered, right on the software documentation page. You must have a ROOTED android device in order for most of the features to work.
Dec 1, 2013 at 5:59 PM
I have the same issue described above. My device is a rooted Kindle (definitely rooted) -- I can connect to it but only see a folder with a slash in the explorer view. I have installed a couple of apk's with DE and am also able to see a long list of device properties.
Jan 2, 2014 at 1:23 AM
Besides root, you have to have busybox installed. If you do have busybox, can you tell me what version you are running of busybox?
Feb 10, 2015 at 8:31 AM
Ok, I have installed on my phone BusyBox Installer (by JRummy Apps Inc.), and I've used it to install BusyBox v1.20.2

Now Droid Explorer has populated the tree under /

But it is still running in normal user mode, so folder /data/ appears to be empty.

How can I get Droid Explorer to connect to my phone as superuser? (My phone is obviously rooted, but Droid Explorer doesn't seem to ask for su)
Feb 16, 2015 at 1:20 PM

My problem was that ADB cannot run as root on production ROM's (i.e. Stock ROM's, unless you've bought a "development version" of your smartphone).

After flashing Cyanogen Mod 11 on my LGL90, I was able to go into Settings--> Superuser --> LocalMenu --> Settings --> Superuser Access --> "Apps and ADB"
(I am Italian and my menus are in Italian, so english menu may differ from my translations I've used here above)

With such settings, ADB server can run in root mode, and Droid Explorer gains access to ALL the file system of the Android Device.


Flashing customs (or even original) ROM's may BRICK your device (i.e. it could become totally unusable).


If your device has a blocked bootloader, you have to unlock it by flashing a custom recovery.


Flashing a custom recovery appears to be an irreversible operation!

While if you just root you device, you can unroot it, gaining back your warranty (you can pretend you've never rooted it), you cannot restore the original recovery, so you can NOT pretend you haven't broken the warranty clause.