This project has moved and is read-only. For the latest updates, please go here.

Me too: Unable to locate Android SDK directory

Aug 2, 2014 at 3:21 AM
Sorry to start a new thread on old subject, but I've been struggling all afternoon with this and I'd really like to use this software! I have tried all fixes posted here and elsewhere. Sure hope you're still supporting DroidExplorer.

I'm pointing DE to C:\Development\adt-bundle-windows-x86_64-20140702\sdk during install.
That folder has platform-tools as you require. Platform tools has aapt.exe and adb.exe. (I put ddms.bat in for good measure per some suggested fix.)

My environmental path is: C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files\WIDCOMM\Bluetooth Software\;C:\Program Files\WIDCOMM\Bluetooth Software\syswow64;C:\adb;C:\Development\adt-bundle-windows-x86_64-20140702\sdk;C:\Development\adt-bundle-windows-x86_64-20140702\sdk\tools;C:\Development\adt-bundle-windows-x86_64-20140702\sdk\platform-tools

FWIW, I did have device (Kindle Fire HD) plugged in while I was installing.

Thanks very much for help.

I don't see attachment option here, so here's log file from Roaming path:
2014-08-01 18:49:09,935   [1    ][ DEBUG] [DroidExplorer.Core.Logger] Settings Loaded from file 'C:\Program Files\Droid Explorer\Data\DroidExplorer.config'
2014-08-01 18:49:10,009   [1    ][ ERROR] [DroidExplorer.Core.Logger] Input string was not in a correct format. - System.FormatException: Input string was not in a correct format.
   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
   at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
   at System.Version..ctor(String version)
   at DroidExplorer.Core.CommandRunner.<GetBuildTool>b__0(DirectoryInfo m) in e:\Development\projects\csharp\droidexplorer\trunk\DroidExplorer\DroidExplorer.Core\CommandRunner.cs:line 391
   at System.Linq.Enumerable.WhereSelectArrayIterator`2.MoveNext()
   at System.Linq.Enumerable.Max[TSource](IEnumerable`1 source)
   at DroidExplorer.Core.CommandRunner.GetBuildTool(String relativePath) in e:\Development\projects\csharp\droidexplorer\trunk\DroidExplorer\DroidExplorer.Core\CommandRunner.cs:line 391
   at DroidExplorer.Core.CommandRunner.GetSdkTool(String relativePath) in e:\Development\projects\csharp\droidexplorer\trunk\DroidExplorer\DroidExplorer.Core\CommandRunner.cs:line 359
   at DroidExplorer.Core.CommandRunner.VerifyAndroidSdkTools() in e:\Development\projects\csharp\droidexplorer\trunk\DroidExplorer\DroidExplorer.Core\CommandRunner.cs:line 379
Nov 22, 2014 at 3:32 PM
Edited Nov 22, 2014 at 3:36 PM
Had the same problem and was able to fix it now. Actually the error message doesn't exactly describe the problem you have to look for.

The DroidExplorerService created these log lines. You get a FormatException somewhere in DroidExplorer.Core.CommandRunner.GetBuildTool. The reason is that you probably have a directory in the SDK folder that doesn't apply to the old version number pattern: \build-tools\android-4.4W
For all All other previous versions the folder names were just numbers like "17.0.0" or "21.1.1". I installed another build tool from the SDK Manager and then removed the folder "android-4.4W" what solved the issue. Most likely renaming it according to the former version pattern does the trick as well ...