Is the Evo supported?

Jul 25, 2010 at 6:49 PM
Edited Jul 25, 2010 at 6:58 PM

I have installed the latest version, I have a rooted stock ROM Sprint Evo. I start the application and what it connects to is:


[[My Device Serial Number]] (as numbers and letters, not the text "My Device Serial Number")


I can't see any of the applications or directory structures. I can only see them when/if I start screencast and then click the "Explorer" button at the top of the screencast, then I can see my directory structure and see the various files.


I'd like to be able to use the application as I imagine others are using it.


Any help would be most appreciated.

Jul 26, 2010 at 11:05 AM

Sounds like the only thing you are missing is busybox. This requirement will not be required in the near future, but current releases do require it.

Jul 26, 2010 at 12:20 PM

Is there a place to get it? I know I have busybox installed on the Evo device as it's required for Titanium Backup. So, I know I have it there. Is there another version that needs to run on the Windows XP desktop as well? Can't find it doing a google search.


Jul 26, 2010 at 11:50 PM

can you open DE and go to the Tools->Options and find the "debug window" and set enable on start to "true". then restart DE and post what the output is in the debug window. Also, I have approved your request for being a Documentation contributor. Thank you for offering.

Jul 27, 2010 at 12:39 AM

This is the output of the debug console:


Droid Explorer Debug Console
[CommandRunner] adb.exe -s HT05VHL04817 shell busybox ls -lF --color=never "/"
[CommandRunner] busybox: permission denied

[CommandRunner] adb.exe -s HT05VHL04817 shell busybox ls -lF --color=never "/"
[CommandRunner] busybox: permission denied


Jul 27, 2010 at 11:17 AM

hmmm it seems that you don't have permission to execute busybox. can you go to the directory that busybox is located in and check the permissions?

ls -l /path/to/busybox

you will see something like this:

-rwxr-xr-x    1 root     shell       427508 Aug  1  2008 busybox

if you don't see -rwxr-xr-x then you need to change the permissions. to do that, you will want to do the following from a console or adb shell.

$ su
# chmod 755 busybox
# exit

You should then be able to run busybox without any parameters and see something close to this, your version is probably different.

$ busybox

BusyBox v1.16.2androidfull (2010-03-28 22:34:45 EDT) multi-call binary.
Copyright (C) 1998-2009 Erik Andersen, Rob Landley, Denys Vlasenko
and others. Licensed under GPLv2.
See source distribution for full notice.

Usage: busybox [function] [arguments]...
   or: function [arguments]...

        BusyBox is a multi-call binary that combines many common Unix
        utilities into a single executable.  Most people will create a
        link to busybox for each function they wish to use and BusyBox
        will act like whatever it was invoked as.

Currently defined functions:
        [, [[, arp, ash, awk, basename, bbconfig, brctl, bunzip2, bzcat, bzip2,
        cal, cat, catv, chgrp, chmod, chown, chroot, cksum, clear, cmp, cp,
        cpio, cut, date, dc, dd, depmod, devmem, df, diff, dirname, dmesg,
        dnsd, dos2unix, du, echo, ed, egrep, env, expr, false, fdisk, fgrep,
        find, fold, free, freeramdisk, fuser, getopt, grep, gunzip, gzip, head,
        hexdump, id, ifconfig, insmod, install, ip, kill, killall, killall5,
        length, less, ln, losetup, ls, lsmod, lspci, lsusb, lzop, lzopcat,
        md5sum, mkdir, mke2fs, mkfifo, mkfs.ext2, mknod, mkswap, mktemp,
        modprobe, more, mount, mountpoint, mv, nc, netstat, nice, nohup,
        nslookup, ntpd, od, patch, pgrep, pidof, ping, pkill, printenv, printf,
        ps, pwd, rdev, readlink, realpath, renice, reset, rm, rmdir, rmmod,
        route, run-parts, sed, seq, setsid, sh, sha1sum, sha256sum, sha512sum,
        sleep, sort, split, stat, strings, stty, swapoff, swapon, sync, sysctl,
        tac, tail, tar, tee, telnet, test, tftp, time, top, touch, tr,
        traceroute, true, tty, tune2fs, umount, uname, uniq, unix2dos, unlzop,
        unzip, uptime, usleep, uudecode, uuencode, vi, watch, wc, wget, which,
        whoami, xargs, yes, zcat

Jul 27, 2010 at 11:49 AM

No matter how many times I follow the advice and do a chmod 755 /sdcard/busybox the permissions are always the same:


# chmod 755 /sdcard/busybox
chmod 755 /sdcard/busybox
# ls -l /sdcard/busybox
ls -l /sdcard/busybox
----r-xr-x system   sdcard_rw  1001388 2010-06-27 12:06 busybox

then when I try to run it, I get the following message:

ls -l /sdcard/busybox
----r-xr-x system   sdcard_rw  1001388 2010-06-27 12:06 busybox
# exit
$ busybox
busybox: permission denied

I have no idea why the permissions are not changing, I have su rights.


Jul 27, 2010 at 12:23 PM

i dont think you can execute from /sdcard/. usually you have to install busybox; see How to install busybox for some info. Like usually you move it to /data/local/bin or something like that. then you chmod that with 755, and then you run "busybox --install ."
Jul 27, 2010 at 12:33 PM
Edited Jul 27, 2010 at 12:35 PM

It worked, the link you sent me, worked perfectly exactly as written. I skipped a few steps like using astro to copy to the /system/xbin, but otherwise, it worked great.


Rebooting now.

And, once rebooted, everything looks exactly as expected.

Thank you,

I'm guessing this is one of those things that will make the Evo compatible with Droid Explorer.



Jul 27, 2010 at 4:14 PM

busybox was the missing requirement. I think the problem was that either it was not able to run from the location you had it (maybe for security reasons) or the path of busybox was not in the environment PATH variable.


I hope to have the busybox requirement removed by the 0.9 release, but it might be closer to the 0.9.5 release :) I also plan on making a plugin that will setup and install busybox on the device (if you have root) for you, you just have to have the busybox binary. but that will be after or around the time of 0.9.x as well.

Jul 27, 2010 at 8:25 PM

The only reason I even had busybox was for Titaniuim Backup. Titanium Backup downloaded it and put it on the SD card. Wasn't able to find it anywhere else. Now though, I have it in two locations. Where Titanium Backup wants it and in the directory where it's installed.

Jul 28, 2010 at 11:28 AM

if you ask me, that is a poor design by Titanium Backup, it should require the user to install it, or it should actually install it. but it should install it in a "common" bin directory that is in the PATH so everyone can use it, it should also check if it is installed before downloading and creating a second copy of it. 

Jul 28, 2010 at 12:11 PM
Not disagreeing this assessment at all. I'm going to send the developers of Titanium Backup a bug report. If they're going to require, via a button in their program's interface, that users download busybox, they should make it universally available and install it in a central location for other applications.